[string]$Configurationfile =

Apr 17, 2009 at 5:26 AM
Hi all, trying to work through the script and not sure how to populate this section of the .ps1 file?  I have tried the following and the script errors out?

[

 

string]$Configurationfile = "C:\Users\ryanph\Documents\Software\SharePoint Backup\spbackup1.2\SPBackup.xml" $(throw "need parameter Configurationfile (e.g. ""c:\SpBack\SPBackup.xml"")")

Is there a particular way I should enter this?  Possibly use a share UNC path instead of the full path?

Thanks
...Ryan

 

Apr 28, 2009 at 12:35 PM
Hi Ryan,

You don't need to modify the ps1 script at all, all amendments of this kind should be made within the xml file.

To tell the powershell script to read from the xml script, execute the following command line.

(Place files within C:\SPBackup)

C:\SPBackup\SPBackup.ps1 C:\SPBackup\SPBackup.xml
Apr 28, 2009 at 6:18 PM

Hi Kev, thanks for the information. I am receiving the following error after configuring the XML file and wondering whether I need to edit the .ps1 file, based on the error below:

PS C:\Windows\system32> C:\Users\ryanph.REDMOND\Documents\Software\SharePoint\spbackup1.2\spbackup.ps1 need parameter Configurationfile (e.g. "c:\SPBackup\SPBackup.xml")

At C:\Users\ryanph.REDMOND\Documents\Software\SharePoint\spbackup1.2\spbackup.ps1:16 char:41

kind regards,

______________________________

Ryan J. Phillips :: BPOS Migration Manager

Microsoft Business Online Service Delivery (BOSD)

( 425-538-1286 F Redmond, WA

Apr 28, 2009 at 6:31 PM

I got it working, thanks Kev. Turns out I must run this on the SharePoint server, as it calls stsadm which I wasn’t aware of. I was looking for a powershell remote backup solution where I could run this from anywhere and backup my site collection.

Does anyone know whether a powershell solution that might use WebDAV or other protocol to provide this solution?

From: Ryan Phillips
Sent: Tuesday, April 28, 2009 11:18 AM
To: 'spbackup@discussions.codeplex.com'
Subject: [spbackup:53614]

Hi Kev, thanks for the information. I am receiving the following error after configuring the XML file and wondering whether I need to edit the .ps1 file, based on the error below:

PS C:\Windows\system32> C:\Users\ryanph.REDMOND\Documents\Software\SharePoint\spbackup1.2\spbackup.ps1 need parameter Configurationfile (e.g. "c:\SPBackup\SPBackup.xml")

At C:\Users\ryanph.REDMOND\Documents\Software\SharePoint\spbackup1.2\spbackup.ps1:16 char:41

kind regards,

______________________________

Ryan J. Phillips :: BPOS Migration Manager

Microsoft Business Online Service Delivery (BOSD)

( 425-538-1286 F Redmond, WA