invalid Backup name

Mar 26, 2009 at 10:50 PM
Edited Mar 26, 2009 at 10:50 PM
great script. the hive and iis backup and then I get this error in Powershell Invalid backup name. any ideas.

thanks
Mar 28, 2009 at 3:15 PM
I get this error too.  The only thing I see wrong is that my metabase backup zip file that is created is empty.  This has led to an adventure in learning to debug powershell scripts.  This is my first use of powershell.  Anyone have any clue what our 1 or 2 issues may be?
Coordinator
Mar 31, 2009 at 8:50 AM
Hello,

I am working on the next version of the script and belive this will also solve this issue you have. I hope to have it ready within one week from now.

Best regards
Jesper
Apr 28, 2009 at 1:23 PM
Hi Jesper,

You mentioned an updated release that was expected to resolve this issue.

I am a bit of a newbie, but I am willing to assist where possible, it would be great to get this part of the script working. I am investigating using this script as our Sharepoint backup tool and will then be invoking a BCDR test to see how we can use the files in a recovery scenario onto a different front-end web server and a different back-end SQL server.

I am hoping that this is a supported scenario for this script.
Jul 14, 2009 at 9:11 PM

Hi Jesper,

I just wanted to follow up as well and see if there was any progress on a fix for the issue above.

Thanks.

Sep 17, 2009 at 8:46 PM

Hi Jesper,

I'm also wondering if you made any progress on the issue?
J
Nov 25, 2009 at 1:19 PM
Hi,
replace this line
	   & cscript.exe $env:windir\system32\iisback.vbs /backup /e $iisencryptopassword /b $env:computername /overwrite
with
	   & cscript.exe $env:windir\system32\iisback.vbs /backup /e $iisencryptopassword /overwrite
and this line
	 & cscript.exe $env:windir\system32\iisback.vbs /backup /b $env:computername /overwrite
with
	 & cscript.exe $env:windir\system32\iisback.vbs /backup /overwrite
and this line
	ls $env:windir\system32\inetsrv\metaback\$env:computername.* | out-zip $backupdestination"\"$backupfilename"-IISMetadata"$guid".zip" $_
with
	ls $env:windir\system32\inetsrv\metaback\ | sort @{expression={$_.LastWriteTime}}, @{expression={$_.LastWriteTime};Ascending=$True} | select -last 2
The first two changes will make the script to backup IIS settings using default name (for some unknown reason the /b parameter that specifies the name doesn't work) and the last one picks the newest 2 files from the last backup & zips them.
Jan 31, 2010 at 8:51 PM

Hi,

 

The issue is likely to be an incompatibility in the iisbackup.vbs script and the characters it accepts for the backup name. Testes and fixed this on Win2k3 server

Appearently is does not like the character '-' (and others???)  To work around it I did the following:

# Fix replace minus '-' in computername with '_' because it is invalid in IIS Meta backup name in Win 2003
$computername = $env:computername
If ($QueryOS.contains("2003"))
{
  $computername = $computername.replace("-","_")
}

In the call to the backup script use $computername in stead of $env:computername

& cscript.exe $env:windir\system32\iisback.vbs /backup /e $iisencryptopassword /b $computername /overwrite

(Do the above twice in the with and without encryption password commands)

This will need some further testing but I could not get the specs for IIS Meta backup naming convention.

GWS